Kali Linux: Hacking Networks Part 1

23
27



It’s so easy to hack badly configured networks using Kali Linux! Make sure you have configured your networks securely! Otherwise, look at how simple it is to hack networks using Kali Linux running on a Windows 10 computer. Applications like Yersinia make hacking with Kali Linux super easy! It’s important that you as a network professional know how to protect networks from hackers. Even the new Cisco CCNA 200-301 exam covers some of these hacking topics. Don’t just learn the theory of hacking, learn how to hack practically.

In this Ethical Hacking with Kali Linux playlist, I’m going to show you step by step how to hack and protect networks. This is white-hat hacking, not black-hat – in other words this is about teaching you Ethical hacking to help you better secure your networks!

In this video I’ll show you how to get started with Yersinia and hack CDP and Spanning Tree Protocol (STP). In subsequent videos I’ll show you how to hack other protocols.

Menu:
Overview: 0:01
Yersinia Overview: 0:58
Install Yersinia: 3:08
Yersinia options: 4:07
Run Yersinia: 4:40
Use Putty to view Switch configuration: 5:38
Bridge Kali Linux to the physical Ethernet network: 10:28
CDP flooding: 11:40
Spanning Tree (STP) hacking: 13:49

======================
Previous Video:
======================
Kali Linux installation video:

======================
CCNA content:
======================
Free CCNA content:

CCNA course:

======================
Free Network Software:
======================
Solar-PuTTY:
SolarWinds TFTP Server:
WAN Killer:
Engineers Toolset:
IP Address Scanner:
Network Device Scanner:
Wifi Heat Map:
Wifi Analyzer:
SolarWinds NPM:

kali linux
Hacking
Ethical hacking

EVE-NG
GNS3
VIRL
Packet Tracer
10x Engineer
CCNA
Cisco Devnet Associate

CCNP Enterprise
CCNP Security
CCNP Data Center
CCNP Service Provider
CCNP Collaboration
Cisco Certified Devnet Professional
Cisco Certified Network Professional

LPIC 1
LPIC 2
Linux Professional Institute
LX0-103
LX0-104
XK0-004

Please note that links listed may be affiliate links and provide me with a small percentage/kickback should you use them to purchase any of the items listed or recommended. Thank you for supporting me and this channel!

========================
Switch configuration:
========================

c2960-CG# sh run
Building configuration…

Current configuration : 2984 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c2960-CG
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
!
ip dhcp pool vlan1
network 10.1.1.0 255.255.255.0
default-router 10.1.1.254
dns-server 10.1.1.254
!
ip dhcp pool vlan2
network 10.1.2.0 255.255.255.0
default-router 10.1.2.254
dns-server 10.1.2.254
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface Vlan1
ip address 10.1.1.254 255.255.255.0
no ip route-cache
!
interface Vlan2
ip address 10.1.2.254 255.255.255.0
no ip route-cache
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
line con 0
line vty 0 4
password cisco
login
transport input all
line vty 5 15
login
!
end

========================

#kalilinux #ethicalhacking #hacker

Nguồn:https://dantrionline.com.vn/


https://danhnhan.vn/cong-nghe

23 COMMENTS

  1. Menu:

    Overview: 0:01
    Yersinia Overview: 0:58
    Install Yersinia: 3:08
    Yersinia options: 4:07
    Run Yersinia: 4:40
    Use Putty to view Switch configuration: 5:38
    Bridge Kali Linux to the physical Ethernet network: 10:28
    CDP flooding: 11:40
    Spanning Tree (STP) hacking: 13:49

    ======================
    Previous Video:
    ======================
    Kali Linux installation video: https://youtu.be/AnwgxRtWXLI

    ======================
    CCNA content:
    ======================
    Free CCNA content: https://www.youtube.com/playlist?list=PLhfrWIlLOoKM3niunUBTLjOR4gMt_uR_a
    CCNA course: http://bit.ly/2PmTVPD

    ======================
    Free Network Software:
    ======================
    Solar-PuTTY: http://bit.ly/SolarPutty
    SolarWinds TFTP Server: http://bit.ly/2mbtD6j
    WAN Killer: http://bit.ly/wankiller
    Engineers Toolset: http://bit.ly/gns3toolset
    IP Address Scanner: http://bit.ly/swipscan
    Network Device Scanner: http://bit.ly/swnetscan
    Wifi Heat Map: http://bit.ly/wifiheat
    Wifi Analyzer: http://bit.ly/swwifianalyzer
    SolarWinds NPM: http://bit.ly/getnpm

    ========================
    Switch configuration:
    ========================

    c2960-CG#sh run
    Building configuration…

    Current configuration : 2984 bytes
    !
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname c2960-CG
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    !
    ip dhcp pool vlan1
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.254
    dns-server 10.1.1.254
    !
    ip dhcp pool vlan2
    network 10.1.2.0 255.255.255.0
    default-router 10.1.2.254
    dns-server 10.1.2.254
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    !
    !
    !
    !
    !
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    switchport access vlan 2
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/3
    !
    interface GigabitEthernet0/4
    !
    interface GigabitEthernet0/5
    !
    interface GigabitEthernet0/6
    !
    interface GigabitEthernet0/7
    !
    interface GigabitEthernet0/8
    !
    interface GigabitEthernet0/9
    !
    interface GigabitEthernet0/10
    !
    interface Vlan1
    ip address 10.1.1.254 255.255.255.0
    no ip route-cache
    !
    interface Vlan2
    ip address 10.1.2.254 255.255.255.0
    no ip route-cache
    !
    ip http server
    ip http authentication local
    ip http secure-server
    !
    !
    !
    !
    line con 0
    line vty 0 4
    password cisco
    login
    transport input all
    line vty 5 15
    login
    !
    end

    ========================

  2. I can't update : shows this error

    E: Could not open lock file /var/lib/dpkg/lock-frontend – open (13: Permission denied)

    E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

    kali@kali:~$

  3. David I have tried the kali installation on win 10 with VMWARE workshop but the ifconfig command is not working, error appears on the screen..kindly guide me how to resolve this error?

  4. What is I don’t have this switch and set up, but I have a Mac Pro laptop and a Lenovo laptop? What should I do, to practicing hacking those? Or is it a online lab I can you? Please help

  5. @DavidBombal how would one defend themselfs from this as ive had two different internet companies and after a couple weeks seems like this is what happens to me. Ive read along the way to use wireshark and have some saved capture files from when it was happening but dont know how to read them..

LEAVE A REPLY

Please enter your comment!
Please enter your name here